Error message when sending a test email or submitting a job

Note: this tutorial applies to JungleMail 4 and earlier only. If you are working with JungleMail 5 this tutorial does not apply to your version of JungleMail.

Symptoms:

An error  message appears when  the user  sends  a test  email or submits a Job.

1. Error message:

JungleMail is unable to send e-mails because of error in configuration. E-mail From address is not specified. Please configure Outgoing E-Mail Settings in JungleMail Site Collection Settings or JungleMail Global Settings in SharePoint Central Administration.

Occurs:

Occurs when  user  sends  test  email or submits a Job.

Cause:

JungleMail is unable to resolve “From” field address for sending emails.

Outcome:

JungleMail fails to send any emails.  User is unable to submit a Job.

Solution:

Specify From email address.

From email address can be configured on different levels:

  1. SharePoint global configuration:  
    SharePoint Central Administration >System Settings > Configure outgoing e-mail settings > From address.
  2. SharePoint Web Application level configuration: 
    SharePoint Central Administration > Application Management > Manage web applications > Select Web Application > General Settings > Outgoing E-mail > From address.
  3. JungleMail global configuration:
    SharePoint Central Administration > JungleMail global settings > E-Mail “From” Field.
  4. JungleMail Site Collection level configuration:
    Site Settings > Site Collection Administration > EnovaPoint JungleMail Settings > E-Mail “From” Field.

2. Error message:

JungleMail is unable to send e-mails because of error in configuration. E-mail From address is not specified. Please configure Outgoing E-Mail Settings in JungleMail Site Collection Settings or JungleMail Global Settings in SharePoint Central Administration. (Error: Unable to parse your e-mail address. Please check your e-mail address.)

Occurs:

Occurs when a  user  sends  test email or submits a Job.

Cause:

JungleMail settings are set to use job author email address for From field, but current user does not have  an email  address specified in User Information list on current Site Collection

Outcome:

JungleMail  is failing  to send emails from  current  user. Current user is unable to submit a Job.

Solutions:

1. Change From address settings

From email address settings can be changed on different levels:

  • JungleMail global configuration: 
    SharePoint Central Administration > JungleMail global settings > E-Mail “From” Field.
  • JungleMail Site Collection level configuration: 
    Site Settings > Site Collection Administration > EnovaPoint JungleMail Settings > E-Mail “From” Field.

2. For users: Ask your administrator to check why your SharePoint user does not have an email  address specified in User Information list on current Site Collection. This can be caused by User Profiles Service misconfiguration.

3. For Administrators: If you are using system account without  an email  address, navigate to My Settings > Edit item and enter your email address or use another user account which has an email address

3. Error message:

JungleMail is unable to send e-mails because of error in configuration. SMTP server address is not specified. Please configure Outgoing E-Mail Settings in JungleMail Site Collection Settings or JungleMail Global Settings in SharePoint Central Administration.

Occurs:

Occurs when  user  sends  test  email or submits a Job.

Cause:

JungleMail is unable to resolve the SMTP server address for sending emails.

Outcome:

JungleMail fails to send any emails.  A user is unable to submit a Job.

Solution:

Specify SMTP server address.

SMTP server address can be configured on different levels:

  1. SharePoint global configuration: 
    SharePoint Central Administration > System Settings > Configure outgoing e-mail settings > Outbound SMTP server.
  2. SharePoint Web Application level configuration: 
    SharePoint Central Administration > Application Management > Manage web applications > Select Web Application  > General Settings > Outgoing E-mail > Outbound SMTP server.
  3. JungleMail global configuration:
    SharePoint Central Administration > JungleMail global settings > Outbound SMTP server.
  4. JungleMail Site Collection level configuration:
    Site Settings > Site Collection Administration > EnovaPoint JungleMail Settings > Outbound SMTP server.
Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us